Appendix B. DHCPv6 Message Types and Option Codes
DHCP MESSAGE TYPES
Registry Value | Description | Reference |
|---|---|---|
Source: RFC3315 | ||
0 | Reserved | RFC3315 |
1 | SOLICIT | RFC3315 |
2 | ADVERTISE | RFC3315 |
3 | REQUEST | RFC3315 |
4 | CONFIRM | RFC3315 |
5 | RENEW | RFC3315 |
6 | REBIND | RFC3315 |
7 | REPLY | RFC3315 |
8 | RELEASE | RFC3315 |
9 | DECLINE | RFC3315 |
10 | RECONFIGURE | RFC3315 |
11 | INFORMATION-REQUEST | RFC3315 |
12 | RELAY-FORW | RFC3315 |
13 | RELAY-REPL | RFC3315 |
14 | LEASEQUERY | RFC3315 |
15 | LEASEQUERY-REPLY | RFC5007 |
16-255 | UNASSIGNED | RFC5007 |
DHCP OPTION CODES
Registry Value | Description | Reference |
|---|---|---|
Source: RFC3315. | ||
0 | Reserved | RFC3315 |
1 | OPTION_CLIENTED | RFC3315 |
2 | OPTION_SERVERID | RFC3315 |
3 | OPTION_IA_NA | RFC3315 |
4 | OPTION_IA_TA | RFC3315 |
5 | OPTION_IAADDR | RFC3315 |
6 | OPTION_ORO | RFC3315 |
7 | OPTION_PREFERENCE | RFC3315 |
8 | OPTION_ELAPSED_TIME | RFC3315 |
9 | OPTION_RELAY_MSG | RFC3315 |
10 | Unassigned | RFC3315 |
11 | OPTION_AUTH | RFC3315 |
12 | OPTION_UNICAST | RFC3315 |
13 | OPTION_STATUS_CODE | RFC3315 |
14 | OPTION_RAPID_COMMIT | RFC3315 |
15 | OPTION_USER_CLASS | RFC3315 |
16 | OPTION_VENDOR_CLASS | RFC3315 |
17 | OPTION_VENDOR_OPTS | RFC3315 |
18 | OPTION_INTERFACE_ID | RFC3315 |
19 | OPTION_RECONF_MSG | RFC3315 |
20 | OPTION_RECONF_ACCEPT | RFC3319 |
21 | SIP Servers Domain Name List | RFC3319 |
22 | SIP Servers IPv6 Address List | RFC3646 |
23 | DNS Recursive Name Server Option | RFC3646 |
24 | Domain Search List option | RFC3633 |
25 | OPTION_IA_PD | RFC3633 |
26 | OPTION_IAPREFIX | RFC3898 |
27 | OPTION_NIS_SERVERS | RFC3898 |
28 | OPTION_NISP_SERVERS | RFC3898 |
29 | OPTION-NIS_DOMAIN_NAME | RFC3898 |
30 | OPTION_NISP_DOMAIN_NAME | RFC4075 |
31 | OPTION_SNTP_SERVERS | RFC4242 |
32 | OPTION_INFORMATION_REFRESH_TIME | RFC4280 |
33 | OPTION_BCMCS_SERVER_D | RFC4280 |
34 | OPTION_BCMCS_SERVER_A | RFC4776 |
35 | Unassigned | RFC4649 |
36 | OPTION_GEOCONF_CIVIC | RFC4580 |
37 | OPTION_REMOTE_ID | RFC4704 |
38 | OPTION_SUBSCRIBER_ID ... | |
Become an O’Reilly member and get unlimited access to this title plus top books and audiobooks from O’Reilly and nearly 200 top publishers, thousands of courses curated by job role, 150+ live events each month,
and much more.
Read now
Unlock full access