Default Routes

EIGRP tracks default routes in the external section of its routing updates. Candidate default routes are marked by setting the flags field to 0x02.

Default routes are most often used to support branch offices that have only one or two connections to the core network (see Figure 4-11).

Branch offices only need a default route

Figure 4-11. Branch offices only need a default route

The core router is configured as follows:

    hostname core1
    !
    interface Ethernet0
     ip address 192.168.1.1 255.255.255.0
    ...
    interface Serial0
    ip address 172.16.245.1 255.255.255.0
    ...
    router eigrp 10
24   redistribute static metric 56 100 255 1 255   
     network 172.16.0.0
    !
    ip classless
25  ip route 0.0.0.0 0.0.0.0 Null0 

The branch router is configured as follows:

    hostname branch1
    ...
    interface Serial0
    ip address 172.16.245.2 255.255.255.0
    ...
26  router eigrp 10                                    
    network 172.16.0.0

An examination of branch1’s routing table would show:

    branch1#sh ip route
    ...
    Gateway of last resort is 172.16.251.1 to network 0.0.0.0

         172.16.0.0/24 is subnetted, 6 subnets
    C       172.16.245.0 is directly connected, Serial0
    ...
27  D*EX 0.0.0.0/0 [170/46251776] via 172.16.245.1, 00:01:47, Serial0

Since the default route is an external route, it is tagged with a distance of 170 (line 27).

The following steps were followed in the creation of this default route:

  1. Network 0.0.0.0 was defined as a static route on core1 (see line 25).

  2. Network 0.0.0.0 was redistributed into EIGRP 10 (see line 24).

  3. A default metric was attached to the redistribution (line 24).

  4. EIGRP 10 was turned on in branch1 (line 26).

To increase the reliability of the connection to branches, each branch may be connected to two core routers. branch1 will now receive two default routes. One router (say, core1) may be set up as the primary, and the second router (core2) as backup. To do this, set up the default from core2 with a worse metric, as we did for IGRP in Chapter 3.

Get IP Routing now with the O’Reilly learning platform.

O’Reilly members experience books, live events, courses curated by job role, and more from O’Reilly and nearly 200 top publishers.