Skip to Content
Internet Core Protocols: The Definitive Guide
book

Internet Core Protocols: The Definitive Guide

by Eric Hall
February 2000
Intermediate to advanced
464 pages
15h 57m
English
O'Reilly Media, Inc.
Content preview from Internet Core Protocols: The Definitive Guide

Name

Destination Unreachable

Synopsis

Destination Unreachable means that the destination network, host, or port number specified in the IP datagram was unreachable. This could be a result of a variety of factors, ranging from a router being unable to find a path to the remote system, to the network refusing to accept connections from this particular sender, among many other factors.

ICMP Message Type

The Message Type for Destination Unreachable is 3.

ICMP Message Codes

Destination Unreachable makes extensive use of the Code field. RFC 792 defined six different possible failure codes, numbered through 5. This list was supplemented by RFC 1122, which added seven additional codes (6 through 12). Finally, RFC 1812 added three more codes (13 through 15), but also declared codes 8 through 10 as either obsolete or inappropriate for non-military usage (for this reason, they are not documented in this book).Table 5.4 lists the Codes currently used by Destination Unreachable

Table 5.4. Codes for Destination Unreachable and Their Meaning

Code

Meaning

0

Network Unreachable

1

Host Unreachable

2

Protocol Unreachable

3

Port Unreachable

4

Fragmentation Required but DF Bit Is Set

5

Source Route Failed

6

Destination Network Unknown

7

Destination Host Unknown

8

Source Host Isolated (obsolete)

9

Destination Network Administratively Prohibited (obsolete)

10

Destination Host Administratively Prohibited (obsolete)

11

Destination Network Unreachable for Type-of-Service

12

Destination Host Unreachable for Type-of-Service

13

Communication ...

Become an O’Reilly member and get unlimited access to this title plus top books and audiobooks from O’Reilly and nearly 200 top publishers, thousands of courses curated by job role, 150+ live events each month,
and much more.

Read now

Unlock full access

More than 5,000 organizations count on O’Reilly

AirBnbBlueOriginElectronic ArtsHomeDepotNasdaqRakutenTata Consultancy Services

QuotationMarkO’Reilly covers everything we've got, with content to help us build a world-class technology community, upgrade the capabilities and competencies of our teams, and improve overall team performance as well as their engagement.
Julian F.
Head of Cybersecurity
QuotationMarkI wanted to learn C and C++, but it didn't click for me until I picked up an O'Reilly book. When I went on the O’Reilly platform, I was astonished to find all the books there, plus live events and sandboxes so you could play around with the technology.
Addison B.
Field Engineer
QuotationMarkI’ve been on the O’Reilly platform for more than eight years. I use a couple of learning platforms, but I'm on O'Reilly more than anybody else. When you're there, you start learning. I'm never disappointed.
Amir M.
Data Platform Tech Lead
QuotationMarkI'm always learning. So when I got on to O'Reilly, I was like a kid in a candy store. There are playlists. There are answers. There's on-demand training. It's worth its weight in gold, in terms of what it allows me to do.
Mark W.
Embedded Software Engineer

You might also like

The Tao of Network Security Monitoring Beyond Intrusion Detection

The Tao of Network Security Monitoring Beyond Intrusion Detection

Richard Bejtlich
HTTP protocols

HTTP protocols

Ilya Grigorik

Publisher Resources

ISBN: 1565925726Errata Page