O'Reilly logo

Cisco IOS Cookbook, 2nd Edition by Ian Brown, Kevin Dooley

Stay ahead with the world's most comprehensive technology and business learning platform.

With Safari, you learn the way you learn best. Get unlimited access to videos, live online training, learning paths, books, tutorials, and more.

Start Free Trial

No credit card required

Configuring a Basic MPLS PE Router

Problem

You want to configure a Provider Edge (PE) router to connect your MPLS core to a customer network.

Solution

To configure a PE router, you must set up connections to the MPLS core as well as to one or more customer networks. Further, to distribute customer VRF routing information to other PE routers, you must configure MP-BGP:

Router-PE1#configure terminal
Enter configuration commands, one per line.  End with CNTL/Z.
Router-PE1(config)#ip cef
Router-PE1(config)#mpls ip
Router-PE1(config)#interface Serial0/0
Router-PE1(config-if)#description Connection to Router-P1
Router-PE1(config-if)#ip address 10.1.1.13 255.255.255.252
Router-PE1(config-if)#mpls ip
Router-PE1(config-if)#exit
Router-PE1(config)#interface Loopback0
Router-PE1(config-if)#ip address 10.0.0.2 255.255.255.255
Router-PE1(config-if)#exit
Router-PE1(config)#router ospf 99
Router-PE1(config-router)#router-id 10.0.0.2
Router-PE1(config-router)#network 10.0.0.0 0.255.255.255 area 0
Router-PE1(config-router)#exit
Router-PE1(config)#ip vrf NetworkA
Router-PE1(config-vrf)#rd 100:1
Router-PE1(config-vrf)#route-target export 100:1
Router-PE1(config-vrf)#route-target import 100:1
Router-PE1(config-vrf)#exit
Router-PE1(config)#ip vrf NetworkB
Router-PE1(config-vrf)#rd 100:2
Router-PE1(config-vrf)#route-target export 100:2
Router-PE1(config-vrf)#route-target import 100:2
Router-PE1(config-vrf)#exit
Router-PE1(config)#interface Ethernet0/0
Router-PE1(config-if)#description connection to customer ...

With Safari, you learn the way you learn best. Get unlimited access to videos, live online training, learning paths, books, interactive tutorials, and more.

Start Free Trial

No credit card required