Skip to Content
Practical Internet Groupware
book

Practical Internet Groupware

by Jon Udell
October 1999
Beginner
521 pages
15h 28m
English
O'Reilly Media, Inc.
Content preview from Practical Internet Groupware

Email: Fetching and Managing Messages

The POP mechanism is defined in a long series of documents beginning with RFC918 (October 1984, Post Office Protocol) and culminating in RFC1939 (May 1996, Post Office Protocol - Version 3). There is also an obscure companion to RFC1081, RFC1082 (November 1988, Post Office Protocol - Version 3, Extended Service Offerings), that defines a way to use POP for group discussion, in a manner analogous to the IMAP public folder. The author of RFC1082 wrote:

Since mailers and user agents first crawled out of the primordial ARPAnet, the value of discussion groups have been appreciated (though their implementation has not always been understood).

Although never widely implemented, RFC1082 is another illustration of a major theme of this book: the close but problematic relationship between Internet mail and conferencing.

IMAP has also evolved through a long series of documents, from RFC1064 (July 1988, Interactive Mail Access Protocol - Version 2) to RFC2060 (December 1996, Internet Message Access Protocol - Version 4rev1). Confusingly, the expansion of the IMAP acronym changed along the way. Originally intended mainly for online use—that is, while connected to a mail server—IMAP evolved into a superset protocol that also supports disconnected use à la POP.

Because there was some confusion about how an IMAP client locates and gains access to shared mailboxes (public folders) on an IMAP server, RFC2342 (May 1998, IMAP4 Namespace) spells out the mechanism. Said ...

Become an O’Reilly member and get unlimited access to this title plus top books and audiobooks from O’Reilly and nearly 200 top publishers, thousands of courses curated by job role, 150+ live events each month,
and much more.

Read now

Unlock full access

More than 5,000 organizations count on O’Reilly

AirBnbBlueOriginElectronic ArtsHomeDepotNasdaqRakutenTata Consultancy Services

QuotationMarkO’Reilly covers everything we've got, with content to help us build a world-class technology community, upgrade the capabilities and competencies of our teams, and improve overall team performance as well as their engagement.
Julian F.
Head of Cybersecurity
QuotationMarkI wanted to learn C and C++, but it didn't click for me until I picked up an O'Reilly book. When I went on the O’Reilly platform, I was astonished to find all the books there, plus live events and sandboxes so you could play around with the technology.
Addison B.
Field Engineer
QuotationMarkI’ve been on the O’Reilly platform for more than eight years. I use a couple of learning platforms, but I'm on O'Reilly more than anybody else. When you're there, you start learning. I'm never disappointed.
Amir M.
Data Platform Tech Lead
QuotationMarkI'm always learning. So when I got on to O'Reilly, I was like a kid in a candy store. There are playlists. There are answers. There's on-demand training. It's worth its weight in gold, in terms of what it allows me to do.
Mark W.
Embedded Software Engineer

You might also like

How to Develop a Great Digital Strategy

How to Develop a Great Digital Strategy

Jeanne W. Ross, Cynthia M. Beath, Ina M. Sebastian
The Hidden Cost of AI-Assisted Creativity

The Hidden Cost of AI-Assisted Creativity

Léonard Boussioux, Anil Doshi, Oliver Hauser, Kartik Hosanagar
Are You an Authentic Leader or an Authentic Jerk?

Are You an Authentic Leader or an Authentic Jerk?

Hannes Leroy, Michael A. Daniels, Kristin L. Cullen-Lester, Alexandra Gerbasi
What Successful Project Managers Do

What Successful Project Managers Do

W. Scott Cameron, Jeffrey S. Russell, Edward J. Hoffman, Alexander Laufer

Publisher Resources

ISBN: 1565925378Catalog PageErrata