Calendaring/Scheduling
RFC2445 (November 1998, Internet Calendaring and Scheduling Core Object Specification (iCalendar)) defines a common format for the exchange of calendaring and scheduling information across the Internet. The Netscape Calendar export example in Chapter 10, uses this format.
RFC2446 (November 1998, iCalendar Transport-Independent Interoperability Protocol (iTIP): Scheduling Events, BusyTime, To-dos and Journal Entries) describes how calendaring systems work with calendar objects; it defines verbs such as PUBLISH, REQUEST, REPLY, COUNTER (that is, to counterpropose an alternate meeting time), and DECLINE-COUNTER (to decline such a counterproposal).
RFC2447 (iCalendar Message-based Interoperability Protocol (iMIP)) defines how to transport calendar objects in email messages using the MIME type text/calendar.
Become an O’Reilly member and get unlimited access to this title plus top books and audiobooks from O’Reilly and nearly 200 top publishers, thousands of courses curated by job role, 150+ live events each month,
and much more.
Read now
Unlock full access