Skip to Content
Practical Internet Groupware
book

Practical Internet Groupware

by Jon Udell
October 1999
Beginner
521 pages
15h 28m
English
O'Reilly Media, Inc.
Content preview from Practical Internet Groupware

Email: Encryption and Authentication

A series that begins with RFC1040 (January 1988, Privacy Enhancement for Internet Electronic Mail: Part I—Message Encipherment and Authentication Procedures) and culminates in RFC1421 (February 1993, same title) defines protocol extensions and processing procedures used to encrypt and authenticate RFC822 messages. The base64 encoding scheme, used in many Internet protocols to represent binary data using printable ASCII characters, is defined here.

RFC1114 (August 1989, Privacy Enhancement for Internet Electronic Mail: Part II—Certificate-Based Key Management), superseded by RFC1422 (February 1993, same title) defines a public-key infrastructure that supports message encryption and authentication. It does so by interpreting the CCITT 1988 Recommendation X.509 certificate mechanism “to serve the needs of privacy-enhanced mail in the Internet environment.”

I sign all my email messages, and when I do they carry the Multipart/Signed Content-Type: header defined in RFC1847 (October 1995, Security Multiparts for MIME: Multipart/Signed and Multipart/Encrypted).

RFC1991 (August 1996, PGP Message Exchange Formats) describes the use of PGP to encrypt and authenticate messages. RFC2015 (October 1996, MIME Security with Pretty Good Privacy (PGP)) defines the MIME content types application/pgp-encrypted, application/pgp-signature and application/pgp-keys. It specifies how to use MIME to format messages that are signed and/or encrypted using PGP.

A set of documents ...

Become an O’Reilly member and get unlimited access to this title plus top books and audiobooks from O’Reilly and nearly 200 top publishers, thousands of courses curated by job role, 150+ live events each month,
and much more.

Read now

Unlock full access

More than 5,000 organizations count on O’Reilly

AirBnbBlueOriginElectronic ArtsHomeDepotNasdaqRakutenTata Consultancy Services

QuotationMarkO’Reilly covers everything we've got, with content to help us build a world-class technology community, upgrade the capabilities and competencies of our teams, and improve overall team performance as well as their engagement.
Julian F.
Head of Cybersecurity
QuotationMarkI wanted to learn C and C++, but it didn't click for me until I picked up an O'Reilly book. When I went on the O’Reilly platform, I was astonished to find all the books there, plus live events and sandboxes so you could play around with the technology.
Addison B.
Field Engineer
QuotationMarkI’ve been on the O’Reilly platform for more than eight years. I use a couple of learning platforms, but I'm on O'Reilly more than anybody else. When you're there, you start learning. I'm never disappointed.
Amir M.
Data Platform Tech Lead
QuotationMarkI'm always learning. So when I got on to O'Reilly, I was like a kid in a candy store. There are playlists. There are answers. There's on-demand training. It's worth its weight in gold, in terms of what it allows me to do.
Mark W.
Embedded Software Engineer

You might also like

How to Develop a Great Digital Strategy

How to Develop a Great Digital Strategy

Jeanne W. Ross, Cynthia M. Beath, Ina M. Sebastian
Are You an Authentic Leader or an Authentic Jerk?

Are You an Authentic Leader or an Authentic Jerk?

Hannes Leroy, Michael A. Daniels, Kristin L. Cullen-Lester, Alexandra Gerbasi
What Successful Project Managers Do

What Successful Project Managers Do

W. Scott Cameron, Jeffrey S. Russell, Edward J. Hoffman, Alexander Laufer

Publisher Resources

ISBN: 1565925378Catalog PageErrata