Skip to Content
Practical Internet Groupware
book

Practical Internet Groupware

by Jon Udell
October 1999
Beginner
521 pages
15h 28m
English
O'Reilly Media, Inc.
Content preview from Practical Internet Groupware

Email: Semistructured Documents

The notion that messages carry semistructured data is central to this book. RFC934 (January 1985, Proposed Standard for Message Encapsulation) introduces the idea of a message body that is logically divided into regions separated by an “encapsulation boundary.” This idea was elaborated in a series of MIME RFCs, from RFC1341 (June 1992, MIME (Multipurpose Internet Mail Extensions) to RFC2045 (November 1996, MIME (Multipurpose Internet Mail Extensions) Part One: Format of Internet Message Bodies).

This series spells out the basic idea of MIME: a Content-Type: header can specify that a message body contains structured text, image data, other application-specific data, or a composite of these types.

The author of RFC1049 (March 1988, A Content-Type Header Field for Internet Messages) wrote, “A standardized Content-Type field allows mail reading systems to automatically identify the type of a structured message body and to process it for display accordingly.” This idea would become central not only to mailers and newsreaders, which use the Content-Type: header to identify and process rich content and attachments, but also to browsers. RFC2046 (November 1996, Multipurpose Internet Mail Extensions (MIME) Part Two: Media Types) extended and revised RFC1049.

RFC2048 (November 1996, Multipurpose Internet Mail Extensions (MIME) Part Four: Registration Procedures) describes rules and procedures for registering new MIME content types.

A series beginning with RFC1872 ...

Become an O’Reilly member and get unlimited access to this title plus top books and audiobooks from O’Reilly and nearly 200 top publishers, thousands of courses curated by job role, 150+ live events each month,
and much more.

Read now

Unlock full access

More than 5,000 organizations count on O’Reilly

AirBnbBlueOriginElectronic ArtsHomeDepotNasdaqRakutenTata Consultancy Services

QuotationMarkO’Reilly covers everything we've got, with content to help us build a world-class technology community, upgrade the capabilities and competencies of our teams, and improve overall team performance as well as their engagement.
Julian F.
Head of Cybersecurity
QuotationMarkI wanted to learn C and C++, but it didn't click for me until I picked up an O'Reilly book. When I went on the O’Reilly platform, I was astonished to find all the books there, plus live events and sandboxes so you could play around with the technology.
Addison B.
Field Engineer
QuotationMarkI’ve been on the O’Reilly platform for more than eight years. I use a couple of learning platforms, but I'm on O'Reilly more than anybody else. When you're there, you start learning. I'm never disappointed.
Amir M.
Data Platform Tech Lead
QuotationMarkI'm always learning. So when I got on to O'Reilly, I was like a kid in a candy store. There are playlists. There are answers. There's on-demand training. It's worth its weight in gold, in terms of what it allows me to do.
Mark W.
Embedded Software Engineer

You might also like

How to Develop a Great Digital Strategy

How to Develop a Great Digital Strategy

Jeanne W. Ross, Cynthia M. Beath, Ina M. Sebastian
The Hidden Cost of AI-Assisted Creativity

The Hidden Cost of AI-Assisted Creativity

Léonard Boussioux, Anil Doshi, Oliver Hauser, Kartik Hosanagar
Are You an Authentic Leader or an Authentic Jerk?

Are You an Authentic Leader or an Authentic Jerk?

Hannes Leroy, Michael A. Daniels, Kristin L. Cullen-Lester, Alexandra Gerbasi
What Successful Project Managers Do

What Successful Project Managers Do

W. Scott Cameron, Jeffrey S. Russell, Edward J. Hoffman, Alexander Laufer

Publisher Resources

ISBN: 1565925378Catalog PageErrata