Skip to Content
Practical Internet Groupware
book

Practical Internet Groupware

by Jon Udell
October 1999
Beginner
521 pages
15h 28m
English
O'Reilly Media, Inc.
Content preview from Practical Internet Groupware

Directory Services

RFC1034 (November 1987, Domain Names - Concepts and Facilities) discusses the architecture of the DNS, and RFC1035 (November 1987, Domain Names— Implementation and Specification) spells out the implementation details.

Recognizing that the DNS is the only truly global Internet directory but that it could never support per-resource URL resolution, RFC2168 (June 1996, Resolution of Uniform Resource Identifiers, Using the Domain Name System) proposes a hybrid approach: a DNS resource record called Naming Authority Pointer (NAPTR) that maps parts of URIs to domain names. The idea is that a URN can refer, through DNS, to a resolver that produces an address.

LDAP’s purpose was to lower the “high cost-of-entry” that had prevented the widespread use of X.500-style directory services on the Internet. The core protocol is defined in a series that begins with RFC1487 (July 1993, X.500 Lightweight Directory Access Protocol) and ends with RFC2251 (December 1997, Lightweight Directory Access Protocol (v3)). RFC2252 (December 1997, Lightweight Directory Access Protocol (v3): Attribute Syntax Definitions) defines “the framework for developing schemas for directories accessible via the Lightweight Directory Access Protocol.” RFC2254 (December 1997, The String Representation of LDAP Search Filters) defines the LDAP query language illustrated in Chapter 14.

Despite LDAP’s success, the vision of a consolidated Internet white pages service remains elusive. There are many public LDAP directories, ...

Become an O’Reilly member and get unlimited access to this title plus top books and audiobooks from O’Reilly and nearly 200 top publishers, thousands of courses curated by job role, 150+ live events each month,
and much more.

Read now

Unlock full access

More than 5,000 organizations count on O’Reilly

AirBnbBlueOriginElectronic ArtsHomeDepotNasdaqRakutenTata Consultancy Services

QuotationMarkO’Reilly covers everything we've got, with content to help us build a world-class technology community, upgrade the capabilities and competencies of our teams, and improve overall team performance as well as their engagement.
Julian F.
Head of Cybersecurity
QuotationMarkI wanted to learn C and C++, but it didn't click for me until I picked up an O'Reilly book. When I went on the O’Reilly platform, I was astonished to find all the books there, plus live events and sandboxes so you could play around with the technology.
Addison B.
Field Engineer
QuotationMarkI’ve been on the O’Reilly platform for more than eight years. I use a couple of learning platforms, but I'm on O'Reilly more than anybody else. When you're there, you start learning. I'm never disappointed.
Amir M.
Data Platform Tech Lead
QuotationMarkI'm always learning. So when I got on to O'Reilly, I was like a kid in a candy store. There are playlists. There are answers. There's on-demand training. It's worth its weight in gold, in terms of what it allows me to do.
Mark W.
Embedded Software Engineer

You might also like

How to Develop a Great Digital Strategy

How to Develop a Great Digital Strategy

Jeanne W. Ross, Cynthia M. Beath, Ina M. Sebastian
The Hidden Cost of AI-Assisted Creativity

The Hidden Cost of AI-Assisted Creativity

Léonard Boussioux, Anil Doshi, Oliver Hauser, Kartik Hosanagar
Are You an Authentic Leader or an Authentic Jerk?

Are You an Authentic Leader or an Authentic Jerk?

Hannes Leroy, Michael A. Daniels, Kristin L. Cullen-Lester, Alexandra Gerbasi
What Successful Project Managers Do

What Successful Project Managers Do

W. Scott Cameron, Jeffrey S. Russell, Edward J. Hoffman, Alexander Laufer

Publisher Resources

ISBN: 1565925378Catalog PageErrata